HTML emails do not display - SOLVED


Share/Bookmark
Use this forum to get a solution for any technical issue that you have with IncrediMail (not send/receive problems).
Forum rules
Please read them carefully before posting new topic - Forum rules

HTML emails do not display - SOLVED

Postby Brent » Tue May 14, 2013 12:21 am

Your IncrediMail Version: 2.5 (downloaded and installed 1 week ago)
Your Internet Browser Type: Google Chrome
Your Operation System: Windows 7

What have you done before the problem occurred?
This a brand new install of Incredimail, and it is the first time I have installed Incredimail.

If you receive any error message, please quote it precisely:
There are no error messages.

Please provide a full description of the problem:
I have a HTML email that will not display in Incredimail, but displays perfectly fine Thunderbird. I've tried all sorts of things in Incredimail to try and resolve this, but nothing has worked.

I can send and received HTML email to/from Incredimail when it originates from Incredimail (and it displays fine), but this email in question has originated from a PHP script. As you can see from the images, the email displays fine in Thunderbird, it just doesn't show anything in Incredimail.

Any help would be greatly appreciated. Problem Solved. See my response for the solution

Thank you,

Brent

ThunderBird
Image

Incredimail
Image

The email
Code: Select all
Return-Path: brent@localhost.local
Received: from Sooty ([127.0.0.1])
   by localhost
   ; Tue, 14 May 2013 07:51:20 +1000
Date: Tue, 14 May 2013 07:51:20 +1000
Subject: a test HTML message
To: zapp@planetexpress.local
X-PHP-Originating-Script: 0:htmlMimeMail5.php
MIME-Version: 1.0
X-Mailer: htmlMimeMail5 <http://www.phpguru.org/>
From: Brent <brent@localhost.local>
Content-Type: multipart/alternative;
   boundary="=_8ca13f913f038ae63b64e7bb272d292e"
Message-ID: <mmrbdk.3xz@localhost>

--=_8ca13f913f038ae63b64e7bb272d292e
Content-Type: text/plain; charset="ISO-8859-1"
Content-Transfer-Encoding: 7bit


--=_8ca13f913f038ae63b64e7bb272d292e
Content-Type: text/html; charset="ISO-8859-1"
Content-Transfer-Encoding: quoted-printable

<p>Dear Incredimail,</p>

<p>I really like this email client, and I hope to demonstrate it at a confe=
rence coming soon</p>

<p>However I do have a problem<br />
<ul>
  <li>The contents of the email will not display in Incredimail</li>
  <li>The contents of the email will display in Thunderbird</li>
</ul>
</p>

<p>Any assistance will be greatly appreciated</p>
--=_8ca13f913f038ae63b64e7bb272d292e--

[/i]
Last edited by Brent on Tue May 14, 2013 2:44 am, edited 3 times in total.
Brent
IncrediUser
IncrediUser
 
Posts: 2
Joined: Mon May 13, 2013 11:56 pm

Re: HTML emails do not display - SOLVED

Postby Brent » Tue May 14, 2013 2:40 am

In the end it was the eol line endings that were causing problems. The email was sent with line feed but no carriage return. I.e. \n instead of \r\n.

Unfortunately if you tried to copy and paste the email content into an editor and saved then the editor would have converted it \r\n. Of course once that was done the email would display properly. It caused some confusion for a bit while I was trying to figure it out.

It was an interesting problem to solve especially when I had 2 emails open in my editor that looked exactly the same (until you turned on the option to show eol characters).

Hope this is able to help someone.
Brent
IncrediUser
IncrediUser
 
Posts: 2
Joined: Mon May 13, 2013 11:56 pm

Re: HTML emails do not display - SOLVED

Postby IncrediAdmin2 » Tue May 14, 2013 9:21 am

Thank you for taking the time to send your suggestion but IncrediMail doesn't have this feature at the moment.

We will certainly consider adding it in the future, and we thank you for your feedback.
Best regards,

IncrediAdmin2
IncrediMail Customer Support
IncrediAdmin2
IncrediMail Support Team Member
IncrediMail Support Team Member
 
Posts: 4477
Joined: Tue May 15, 2012 11:42 am


Return to Technical Issues (crashes, error messages, etc.)

Who is online

Registered users: asdlee, Google [Bot]